Django : mise à jour de yawd-admin, template pour l’admin de Django

Depuis le 4 mai 2014, Yawd-admin n’a plus été mis à jour par les mainteneurs officiels. Plusieurs forks patchent quelques bugs et apportent une relative compatibilité avec la version 1.7 de django.
J’utilise par ailleurs ce package sur quelques projets, permettant ainsi de disposer d’une interface d’adminitration pour les sites django attrayante et performante. J’ai décidé de le mettre à jour.

Pour le moment, la dernière version stable est compatible à 100% avec django 1.6 et la version de dev avec django 1.7.
Je suis en train de finaliser la 1.8. Ensuite dès que yawd-admin sera compatible avec django 1.9, je commencerai à ajouter de nouvelles fonctionnalités.

Ensuite viendra la question de la reprise officielle de la maintenance de ce package ou la réalisation d’un fork puis publication sur pypi.

Si vous voulez donner un coup de main, le repo de yawd-admin est pour le moment sur github (je vais le migrer sur bitbucket quand j’aurais pris une décision sur fork ou pas).

Il existe un certain de nombre de paquets sympas fournissant un service à peu près équivalent pour django, comme django-grappelli, django-admin-bootstrapped, django-admin-bootstrap ou django-suit parmi ceux que j’ai utilisé et que j’apprécie.

Mais j’aime bien le look de yawd-admin même si tout n’est pas parfait, je vais pouvoir corriger quelques défaults 😉

Migration du blog vers php 7

Mon hébergeur proposant php 7, j’ai décidé d’effectuer la migration ce jour du blog des télécoms. Je n’ai rencontré aucun problème. Néanmoins, si vous rencontrez des difficultés, n’hésitez pas à m’en faire part.

Je trouve que le blog gagne en vitesse, ce qui est cool.

Débat : faut il avoir peur des ondes ?

Ce soir, vous pouvez voir sur la chaîne Public Sénat, un débat intitulé « Faut-il avoir peur des ondes ? » à 23H00, débat animé par Laurent BAZIN.

Les intervenants sont :

  • Marc KHANNE, Réalisateur de « Cherche zones blanches désespérément »
  • Jean-Pierre MARC-VERGNES, Neurologue de l’Inserm, expert auprès de l’ANSES
  • Laurence ABEILLE, Députée (EELV) du Val-de-Marne
  • Erwan SEZNEC, Journaliste à Que Choisir
  • Étienne CENDRIER, Porte-parole de l’association Robin des Toits

Rediffusion le dimanche à 19h, le lundi à 18h15, le samedi suivant à 16h15 et le dimanche suivant à 11h.

Les ondes sont omniprésentes dans notre environnement, GSM, WiFi, bluetooth, radio … Des voix s’élèvent pour dénoncer la nocivité de certaines d’entre elles. Le sont-elles réellement et à quelle dose ? je n’ai pas trouvé d’étude permettant d’affirmer définitivement si certaines ondes sont nocives pour notre santé. Enfin, sommes nous prêt à nous passer des services associés ?

Snom : fin de vie des téléphones SIP 760, 720 et 710

Snom annonce la fin de commercialisation des téléphones SIP 760, 720 et 710 qui seront remplacés respectivement par les D765, D725 et D710. Pendant les 2 années suivantes, Snom mettra à disposition les mises à jour du firmware corrigeant des bugs critiques.

Nouveau thème du blog des télécoms

Nouveau thème, nouvelle interface graphique, le nouveau blog des télécoms débarque. Thématiques : téléphonie, internet, mobile, sécurité

Le blog des télécoms dispose d’un nouveau thème. L’ancien posait plusieurs problèmes et la conception commencée à dater un peu.

J’ai souhaité améliorer la lisibilité et la mise en avant du contenu ainsi que la rapidité du blog. J’apporte une grande importance à la qualité. C’est aussi une des raisons qui m’a poussé à changer d’hébergeur. La nouvelle version du blog des télécoms est maintenant opérationnelle. Il reste encore quelques optimisations et des petits réglages à effectuer.

J’espère que ce nouveau thème vous apportera entière satisfaction. Par ailleurs, si vous souhaitez que j’aborde certains sujets, n’hésitez pas à me contacter. J’ai créé à ce propos une nouvelle rubrique nommée « courriers des lecteurs » qui regroupera ainsi vos questions et remarques ainsi que mes réponses. Je reçois souvent des questions par email et je suis convaincu que les échanges peuvent intéresser d’autres lecteurs. Différents sujets sont souvent abordés comme Asterisk, FreeSwitch, la VoIP mais aussi les problématiques liées à l’ADSL et la fibre optique. Tous les sujets liés aux thématiques du blog des télécoms sont les bienvenues : téléphonie, mobile, internet et sécurité.

Suite à ce changement technique, il se peut que vous rencontriez quelques effets de bord indésirables. Je vous assure néanmoins avoir testé de manière intensive le blog. Si vous rencontrez des problèmes ou si vous voyez des éléments à améliorer, je vous remercie de me laisser un message en commentaire.

 

AstLinux 1.2.3 : corrections de sécurité

Quelques jours après la version 1.2.2, l’équipe d’AstLinux sort une nouvelle version corrigeant plusieurs failles de sécurité (35 !) touchant de nombreux paquets.
Voici la liste :

  • CVE-2015-3331 : patch linux
  • CVE-2014-8964, CVE-2015-2325, CVE-2015-2326 : pcre
  • CVE-2014-9680 : sudo
  • CVE-2015-1572 : e2fsprogs
  • CVE-2014-8128 : tiff
  • CVE-2015-0286, CVE-2015-0287, CVE-2015-0289, CVE-2015-0292, CVE-2015-0293, CVE-2015-0209, CVE-2015-0288, CVE-2015-4000, CVE-2015-1788, CVE-2015-1789, CVE-2015-1790, CVE-2015-1792, CVE-2015-1791 : OpenSSL (version 1.0.1o)
  • CVE-2015-2059 : prosody
  • CVE-2014-9297, CVE-2014-9298, CVE-2015-1798, CVE-2015-1799 : ntpd/sntp
  • CVE-2014-2285 : netsnmp
  • CVE-2015-1419 : vsftpd
  • CVE-2015-3294 : dnsmasq
  • CVE-2015-3144, CVE-2015-3145, CVE-2015-3148, CVE-2015-3143, CVE-2015-3153, CVE-2015-3236, CVE-2015-3237 : libcurl

Un renforcement de la sécurité a été opéré par la création d’un certificat auto-généré unique.

Les versions d’Asterisk ont aussi été mis à jour :

  • Asterisk 1.8.32.3
  • Asterisk 11.18.0
  • Asterisk 13.4.0

Autre nouveauté importante, l’interface graphique d’Asterisk, Digium Asterisk GUI n’est plus inclue dans la solution quelque soit la version d’Asterisk. Je n’ai jamais bien compris l’intérêt de cette interface graphique et de la valeur ajoutée par rapport à l’interface d’AstLinux. Pour rappel, Digium Asterisk GUI est abandonné par l’équipe Asterisk depuis longtemps !

Etant donné l’importance de cette mise à jour, je vous invite à l’appliquer au plus vite sur vos systèmes.

Nouvelle version d’Astlinux 1.2.2 supportant Asterisk 13

Astlinux 1.2.2 vient de sortir. Découvrez les nouveautés d’un IPBX Asterisk embarqué et sécurisé prêt à l’emploi.

L’équipe d’Astlinux vient de sortir une nouvelle version. En dehors des habituelles corrections de bugs ou autres correctifs de sécurité (glibc « GHOST » et OpenSSL), mises à jour (noyau 3.2.66 et Asterisk) et améliorations de l’interface web, la grande nouveauté vient de la prise en charge de Asterisk 13 incluant la stack PJSIP. Toutes les versions d’Astlinux 1.2.2 (version d’Asterisk 1.8 , 11 et 13) intègrent aussi l’application de monitoring monit.

OSX : retour à mDSNResponder

Apple vient de sortir OSX 10.10.4 qui sonne le glas de Discoveryd tellement décrié et remplacé par l’ancien mDNSResponder.

Il pose des problèmes de fonctionnement avec le WiFi et le réseau d’un point de vue général. De nombreux utilisateurs vont être ravis de ce retour en arrière.

Reste à espérer que cette mise à jour va résoudre de nombreux dysfonctionnement comme l’assure Apple, car les problèmes ont malheureusement étaient trop nombreux.

Apple annonce aussi la correction de faille de sécurité, mais lorsque que l’on souhaite en savoir plus voir la réponse d’Apple :

Dans un souci de protection de ses clients, Apple s’interdit de divulguer, d’aborder ou de confirmer l’existence de failles de sécurité tant qu’une enquête approfondie n’a pas été effectuée et que des correctifs ou mises à jour ne sont pas disponibles. Pour obtenir des informations supplémentaires sur la sécurité produit d’Apple, consultez le site Web Sécurité produit d’Apple.

Cela se passe bien sûr de commentaire. J’aime cette transparence !

Est-ce que les récents problèmes de sécurité rencontrés et dénoncés à de nombreuses reprises ont été corrigés ? je l’espère d’autant plus que IOS a aussi été mis à jour.

Sur la page du support d’Apple, les dernières mise à jour concernant OSX concernent Safari et date du 6 mai 2015. Bon OK, ils ont dit qu’ils ne diraient plus rien, mais quand même !!!

Il est grand temps que Apple prenne de nouveau au sérieux ses systèmes d’exploitation et notamment OSX qui semble de plus en plus abandonné au profit d’IOS et de Watch OS (dont je me moque royalement).